更新日:2021-05-26

フラッシュ書き込み用新規 J-Flashプロジェクトを作成します


1ページにまとめて表示

J-Flashツールメニューコマンド一覧:

Fileメニュー

  • Open data file...:ターゲットボードのフラッシュに書き込むデータのイメージファイルを開きます。イメージファイル形式はIntel HEX(*.HEX)、Motorola S(*.MOT、*.SREC)、バイナリ(*.BIN、*.RAW)又はELF(*.ELF)をサポートします。
  • Merge data file...:2つのデータイメージファイル「*.MOT、*.HEX、*.SREC、*.BIN、*.RAW、*.ELF」をマージして一つのデータイメージファイルとして保存します。未使用の空間は「0xFF」データで埋め込みます。
    事例:File0.binとFile1.binを結合して「File3.bin」として保存します。
    File0.bin -->アドレス 0x0200 - 0x02FF
    File1.bin -->アドレス 0x1000 - 0x13FF
    1. 「Open data file...」コマンドでFile0.binを開きます(指定アドレス:0x0200)。
    2. 「Merge data file...」コマンドでFile1.binファイルを開きます(指定アドレス:0x1000)。
    3. 「Save data file as...」コマンドで結合したデータを「File3.bin」として保存します。0x0300 - 0x0FFF空間(GAP)は0xFFデータで埋め込みます。
  • Save data file:開いているデータイメージファイルを保存します。
  • Save data file as...:開いているデータイメージファイルを別のファイルとして保存します。
  • New Project:デフォルト設定で新規のJ-Flashプロジェクトを作成します。
  • Open Project:現在のプロジェクトを終了して“Open Project”ダイログで指定されたプロジェクトを開きます。複数のプロジェクトを同時に開くことは出来ません。
  • Save Project:現在操作中のJ-Flashプロジェクトを保存します。
  • Save Project as...:現在操作中のJ-Flashプロジェクトを別のプロジェクトとして保存します。
  • Close Project:操作中のJ-Flashプロジェクトを終了します。
  • Save Flasher config file...:J-Flashプロジェクトのコンフィグレーション設定をCFGファイルとして保存します。保存するファイルの名前及びパスは“Save configuration file”ダイログで指定可能です。
  • Save Flasher data file...:Flasher本体にロードするためのデータファイル(*.DAT)をローカルフォルダに保存します。保存するファイルの名前及びパスは“Save data file”ダイログで指定可能です。
  • Download config & data file to Flasher:J-Flashプロジェクト用のコンフィグレーション設定ファイル(*.CFG)及びデータファイル(*.DAT)をFlasher本体の内蔵フラッシュROMに書き込みます。ターゲット側のフラッシュメモリにアクセスを行いません。Flasher本体に保存されるDATファイルは、ユーザープログラムのデータそのままではありません。DATファイルには、ターゲット側のマイコン及びフラッシュコントローラ専用のフラッシュ書き込みプログラム(フラッシュ書き込みアルゴリズム)も含まれています。J-Link本体の場合本コマンドは使用出来ません。
  • Download serial number file to Flasher:ターゲット用S/N番号指定ファイルをSERIAL.TXTとしてFlasher本体に保存します。J-Link本体の場合本コマンドは使用出来ません。
  • Recent Files:最近開いたデータファイルの一覧を表示します。
  • Recent Projects:最近開いたJ-Flashプロジェクトファイルの一覧を表示します。
  • Exit:J-Flashプログラムを終了します。

Editメニュー

  • Relocate...:データファイルのオフセットアドレスを指定又は変更します。
  • Delete range...:データファイルからユーザー指定のデータ空間を削除します。削除するデータのスタート及びエンドアドレスを“Enter address range”ダイログで指定します。
  • Eliminate blank areas...:データファイル内のブランク空間を削除します。

Targetメニュー

  • Connect:JTAG/SWDデバッグポート経由でターゲットのマイコンに接続します。プロジェクト設定のターゲットI/Fモードにて接続及び初期化を行います。
  • Disconnect:ターゲットのデバッグポート接続を解除します。
  • Test:ターゲット接続のテストを行います。“Generates test data...”コマンドでテスト用のデータパターンを作成します。テストデータのサイズは指定可能です。“Test speed...”コマンドで指定空間のメモリアクセスの速度をテストします。“Show CFI info...”コマンドでターゲットのCFI対応フラッシュのCFI Query情報を読み出して表示します。
  • Production Programming:Productionコマンドで、「Connect→Erase→Program→Verify」コマンドを順番に行います。Productionコマンドで実行するコマンド順及びフラッシュセクターの選択はプロジェクト設定で指定します。
    ダイレクトコマンドFnキー:F7
  • Manual Programming:J-Flashツールからマニュアルコマンドで「Connect、Erase、Program、Verify、Readback」操作を行います。

Targetメニュー → Manual Programming

  • Check blank:ターゲットのフラッシュデバイスのブランクチェックを行います。
  • Erase sectors:プロジェクト設定で選択されている全てのセクターをイレーズ(0xFFデータ)します。
  • Erase chip:フラッシュデバイスの全てのデータをイレーズします。
  • Program:データイメージをターゲット上のフラッシュメモリに書き込みます。
  • Program & Verify:データイメージをターゲット上のフラッシュメモリに書き込んでデータ内容を比較(ベリファイ)します。
  • Verify:データファイルとフラッシュデバイスのデータをベリファイします。
  • Read back:フラッシュデバイスのメモリデータを読み出して、新しいデータファイルとして保存します。“Selected sectors”コマンドでデータを読み出す場合は、プロジェクト設定で選択されたセクターのデータを読み出します。
    “Entire chip”コマンドの場合は、全てのセクターのデータを読み出します。
    “Range...”コマンドの場合は、ユーザー指定のフラッシュメモリ空間のデータを読み出してファイルとして保存します。
  • Start Application:ターゲット側のフラッシュに書き込んだアプリケーションを起動します。

Optionsメニュー

  • Project settings...:プロジェクト設定ダイログを開きます。ターゲット接続モード、CPU初期化設定及びフラッシュ関連の設定が可能です。
  • Global settings...:グローバル設定を行います。※J-Flashプロジェクトファイルには保存されません。

Viewメニュー

  • Show project information:プロジェクト情報表示ウインドウを開きます。
  • Show log:ログ表示ウインドウを開きます。

前の質問

J-Flash ツールのコマンドライン操作方法

次の質問

Flasher本体のTCP/IPネットワーク設定方法