更新日:2021-05-26

フラッシュ書き込み用新規 J-Flashプロジェクトを作成します


【回答】

J-Flashツールを起動してほぼデフォルトのプロジェクト設定のままマイコン内蔵フラッシュへの書き込みが可能です。多くのマイコン内蔵フラッシュに対応しましたJ-Flashツールは無償で提供しております。

事前準備・ツール設定:

J-FlashツールはFlasher ソフトウェアパッケージに含まれています。事前にFlasher ソフトウェアをインストールしてください。

Flasherソフトウェアのダウンロード及びインストール手順


実行手順:

STEP表示

J-Flashツールの起動:

パソコンのスタートメニューからSEGGERソフトウエアパッケージの「J-Flash」プログラムを実行します。実行後に「Welcome to J-Flash」ダイアログが表示されます。

  1. 「Create new project」項目を選択して「Start J-Flash」ボタンをクリックします。
  2. 「…」をクリックしてターゲットデバイス設定ダイアログを起動します。
  3. ターゲットボードのマイコンデバイス型番を確認してダイアログのデバイス一覧から正しいMCUデバイス名を選択します。
  4. 「OK」ボタンをクリックしますと、デフォルト設定でJ-Flashプロジェクトが作成されます。
Start J-Flash
J-Flash welcome
Start Device

以下、「ST STM32H753XIxx」マイコンデバイスせてい事例のキャプチャです。
STM32H753XIデバイスの書き込み可能なフラッシュ空間:内蔵フラッシュ(2MB、Bank1/Bank2)、外部QSPIフラッシュ(最大64MB)

select MCU
Default J-Flash Project

J-Link/Flasher本体との接続、ターゲットボードのデバッグポートインターフェースの設定を行います。

J-Flashプロジェクト設定:パソコン接続モード

  1. J-Flashメニューから「Options → Project settings...」コマンドを実行してプロジェクト設定ダイアログを開きます。
    USB I/F
  2. パソコンとの接続はUSBケーブルで、J-Link/Flasher本体は1台のみ接続する環境ではデフォルト設定の「connection type: USB」で問題ありません。複数のJ-Link/Flasher本体をパソコンに接続(USB)してJ-Flashを使用する場合は、対象J-Link/Flasher本体をシリアル番号を指定して個別に設定可能です。例えば、J-Flashツールから「661234567」シリアル番号の本体を操作したい場合は、以下のように「connection type: USB SN: 661234567」に設定します。(※シリアル番号は本体の裏面に記載されています)
    USB-SN I/F
    LANケーブル接続でJ-Link/Flasher本体をパソコンに接続する場合は、「connection type: TCP/IP」を選択します。TCP/IP項目に対象J-Link/Flasher本体のIPアドレス又は HOSTNAMEを指定します。J-Link Remote Server経由でのリモート接続も可能です。
    TCP I/F

J-Flashプロジェクト設定:ターゲットインターフェース

ターゲットマイコンとのインターフェースモード(JTAG/SWD/FINE/cJTAG)を設定します。ボード側のデバッグポートインターフェース仕様を確認してモードを設定してください。
※ ターゲットボード側のコネクタ仕様が異なる場合は変換アダプタを使ってください。


SWDモードの設定

「Target Interface」タブの接続モード項目を「SWD」に指定して、ターゲットCPUとのインターフェースをSWDモードに設定可能です。

SWD mode

画面左の“SWD speed before init”項目でCPUの初期化前のSWDクロック値(初期化を行う時のSWDクロック)を設定します。画面右の“SWD speed after init”項目でCPUの初期化後のSWDクロック値(フラッシュ読み書き、ベリファイ等を行う時のSWDクロック)を設定します。自動設定、又はマニュアルクロック(1kHz~12MHz)設定が可能です。
J-Flashプログラムからパソコン経由でフラッシュ書き込みを行う場合は「Auto selection」設定で使用可能です。しかし、スタンドアロン・モードの場合はマニュアル設定が必要となります。


JTAG/cJTAGモードの設定

JTAG/cJTAGインターフェースモードのJTAGチェーン及び速度設定を行います。必ず、ターゲットボードのCPUの仕様に合わせて設定値を指定してください。

JTAG mode

画面左の“JTAG speed before init”項目でCPUの初期化前のJTAGクロック値(初期化を行う時のJTAGクロック)を設定します。画面右の“JTAG speed after init”項目でCPUの初期化後のJTAGクロック値(フラッシュ読み書き、ベリファイ等を行う時のJTAGクロック)を設定します。自動設定、アダプティヴクロック設定又はマニュアルクロック(1kHz~12MHz)設定が可能です。
J-Flashプログラムからパソコン経由でフラッシュ書き込みを行う場合は「Auto selection」設定で使用可能です。しかし、スタンドアロン・モードの場合はマニュアル設定が必要となります。

画面下の“JTAG scan chain information”項目でJTAGポートの詳しい設定を行います。

Auto detection

“Auto detection”項目をチェックし、「Detect」ボタンをクリックしてJTAGスキャンでインターフェースID情報を読み出します。JTAGスキャン情報はLogウインドウに表示されます。“Detailed configuration”項目をチェックして、読み出しましたスキャン情報は確認出来ます。

Simple configuration

“Simple configuration”項目をチェックして、マイコンデバイスのJTAGスキャンチェーン設定を行います。

JTAG Simple config

Detailed configuration

J-Link/Flasher 本体のUSBポートをパソコンに接続しターゲットボードに電源を入れて、“Detailed configuration”項目をチェックして、「Detect」ボタンをクリックしてJTAGスキャンで情報を読み出して表示します。“Detailed configuration”項目ウインドウにマニュアル設定の追加又は編集が可能です。「Verify」ボタンをクリックしてマニュアル設定の確認が可能です。

JTAG Detailes configJTAG Scanchain

FINEモードの設定

Renesas RXマイコン環境の場合は、「Target Interface」タブの接続モード項目を「FINE」に指定して、ターゲットCPUとのインターフェースをFINEモードに設定可能です。

FINE mode

画面左の“FINE speed before init”項目でCPUの初期化前のFINEクロック値(初期化を行う時のFINEクロック)を設定します。画面右の“FINE speed after init”項目でCPUの初期化後のFINEクロック値(フラッシュ読み書き、ベリファイ等を行う時のFINEクロック)を設定します。自動設定、又はマニュアルクロック(1kHz~2MHz)設定が可能です。
J-Flashプログラムからパソコン経由でフラッシュ書き込みを行う場合は「Auto selection」設定で使用可能です。しかし、スタンドアロン・モードの場合はマニュアル設定が必要となります。


J-Flashプロジェクトの設定:MCU

MCU設定ページでマイコン及びターゲット初期化の設定を行います。

MCU Setup

「Device」項目の「…」オプションをクリックして、ナイコンデバイスの変更は可能です。

ターゲットボード接続時、コアの確認を行う際に、「Check core ID」オプション項目にチェックを入れて「ID」項目に正しいコアID番号を設定してください。チェックを行うID番号のビットマスクの設定は「Mask」項目に設定します。

J-Flashが使用するフラッシュローダアルゴリズムがSRAM上実行されます。「Target RAM settings」項目のRAMアドレス及びサイズを確認してください。

J-Flashプログラムは一部のデバイスの場合にCPUクロック設定項目が必要です。J-Flashプログラムからパソコン経由でフラッシュ書き込みを行う場合は「Auto detection」設定で使用可能です。しかし、スタンドアロン・モードの場合はマニュアル設定が必要となります。
※J-Link本体の場合、スタンドアロン・モードは使用出来ません。

ターゲットボード環境でのCPUのクロック設定値が不明の場合は以下の手順を参考にしてください。

  1. 「Clock Speed」項目を「Auto detection」モードに設定し、「OK」をクリックしてプロジェクト設定を保存します。
  2. J-Flashプログラムから「Target→Connect」メニューコマンドを実行します。
  3. ターゲット接続すると、以下のようにLOGコンソールに自動設定で読み出すクロック値が表示されます。
     - Target interface speed: 4000 kHz (Fixed)
     - CPU clock frequency: 64563 kHz (Auto detected)
     - Found 2 JTAG devices. Core ID: 0x6BA00477 (None)
     - Connected successfully
  4. 再度プロジェクト設定ダイアログを開いて、LOGコンソールに表示される「CPU clock frequency」の値(例:64563 kHz)をJ-Flashプロジェクトの「Clock Speed」のFixed項目(単位:Hz)に設定してスタンドアロン・モードで使用します。
    MCU Clock setup

MCU設定:Init. steps設定

ターゲットボードのハードウエア設計によっては、フラッシュメモリアクセスの前に、フラッシュメモリのバスモード設定、クロック設定又はフラッシュ書き込みを有効に設定するためのレジスタ設定等のボード依存分の初期化設定を行う必要があります。
内蔵フラッシュ、(Q)SPIフラッシュ書き込みの場合は、内部初期化処理はフラッシュローダプログラムに含まれていますので、ユーザ指定初期化設定は不要です(デフォルトプロジェクト設定のままで十分です)。

パラレルバス接続のNORフラッシュへの書き込み用プロジェクトの場合は、MCU設定ダイログの画面下の初期化設定項目に「Init steps」を選択して、コマンド設定ボックスにターゲット側のフラッシュメモリの書き込みアクセスのために必要な初期化コマンドを順番に指定します。

Init Steps

コマンド設定ボックスの「+」ボタンで「Add action」ダイログを開き、「Action Type」項目から必要なコマンドをコマンドボックスに追加してください。

Initコマンド一覧:

コマンド説明
Delay指定時間のディレイを設定します。
DisableMMUMMUを無効に設定します。
Disable ChecksJTAGチェックを無効に設定します。
Enable ChecksJTAGチェックを有効に設定します。
GoCPUを起動します。
HaltCPUを停止します。
ResetCPUをリセットします。Reset-TypeについてはJ-Linkマニュアルをご参照ください。
Read 8bit指定アドレスから8bitデータを読み出します。結果値を内部変数に保存します。
Read 16bit指定アドレスから16bitデータを読み出します。結果値を内部変数に保存します。
Read 32bit指定アドレスから32bitデータを読み出します。結果値を内部変数に保存します。
SetAllowRemoteReadターゲットのリモートICEからの読み出しアクセスを有効に設定します。(デフォルト:On)
SetAllowRemoteWriteターゲットのリモートICEからの書き込みアクセスを有効に設定します。(デフォルト:On)
Verify 8bit指定アドレスの8bitデータをベリファイします。
Verify 16bit指定アドレスの16bitデータをベリファイします。
Verify 32bit指定アドレスの32bitデータをベリファイします。
Write 8bit指定アドレスに指定8bitデータを書き込みます。
Write 16bit指定アドレスに指定16bitデータを書き込みます。
Write 32bit指定アドレスに指定32bitデータを書き込みます。
Write&Verify 8bit指定アドレスに指定8bitデータを書き込みます。書き込み後にデータをベリファイします。
Write&Verify 16bit指定アドレスに指定16bitデータを書き込みます。書き込み後にデータをベリファイします。
Write&Verify 32bit指定アドレスに指定32bitデータを書き込みます。書き込み後にデータをベリファイします。
Write Register指定レジスタに指定データを書き込みます。
Write JTAG IRJTAG命令レジスタに書き込みを行います。
Write JTAG DRJTAGデータレジスタに書き込みを行います。
Var AND内部変数と指定データのロジカルANDを行います。
Var OR内部変数と指定データのロジカルORを行います。
VAR XOR内部変数と指定データのロジカルXORを行います。
VAR BEQ「内部変数 == 0」の場合は指定Indexから実行します。
VAR BNE「内部変数 != 0」の場合は指定Indexから実行します。
Var Write 8bit内部変数(8bit)の値を指定アドレスに書き込みます。
Var Write 16bit内部変数(16bit)の値を指定アドレスに書き込みます。
Var Write 32bit内部変数(32bit)の値を指定アドレスに書き込みます。
SetModeBigEndianCP15レジスタのビット7を「1」に設定します。
SetModeLittleEndianCP15レジスタのビット7を「0」に設定します。
Var Write File 8bit内部変数(8bit)の値をデータファイルの指定アドレスに書き込みます。
Var Write File 16bit内部変数(16bit)の値をデータファイルの指定アドレスに書き込みます。
Var Write File 32bit内部変数(32bit)の値をデータファイルの指定アドレスに書き込みます。
Commentコメントを書きます。
Write File 8bitデータファイルの指定アドレスに指定8bitデータを書き込みます。
Write File 16bitデータファイルの指定アドレスに指定16bitデータを書き込みます。
Write File 32bitデータファイルの指定アドレスに指定32bitデータを書き込みます。
Report Error指定エラーコード表示でメッセージボックスを起動します。

MCU設定:Exit steps設定

フラッシュ書き込み後のボード設定が必要な場合は、MCU設定ダイログの画面下の初期化設定項目に「Exit steps」を選択して、コマンド設定ボックスに必要なコマンドを指定してください。
「Exit steps」で指定されたコマンドは、Production Programmingコマンドの実行時に処理されます。

Exit Steps

フラッシュメモリ関連のプロジェクト設定:

プロジェクト設定ダイログの「Flash」ページに、フラッシュメモリデバイス関連の設定を行います。フラッシュ空間(内蔵フラッシュ・外部フラッシュ)毎に設定可能です。
「Disable flash bank」項目にチェック入れて対象フラッシュバンクへの書き込みアクセスは無効に設定出来ます。無効に設定しましたフラッシュバンクメモリ空間に対して書き込みを行いません。

指定されているマイコンデバイスによりまして「Base Address」項目に内蔵フラッシュメモリのスタートアドレスは設定されます。

「Rename」ボタンをクリックしてフラッシュバンクの説明文字列は変更可能です。

例:STM32H753XIデバイスの場合は以下の3つのフラッシュ空間をサポートします。

  • 内蔵フラッシュ(Bank0)
  • 内蔵フラッシュ(Bank1)
  • 外部QSPIフラッシュ
Flash Banks

デバイス内蔵フラッシュ関連の設定

MCU設定ページに内蔵フラッシュのマイコンデバイスが指定された場合は、「Flash」ページにそのフラッシュデバイス用の設定値が自動的に読まれます。

Internal Bank

「Sector selection」グループウインドウからフラッシュ読み書き・ベリファイを行う各セクターの個別選択(アクセスを行うフラッシュメモリ空間の指定)が可能です。選択されていないセクターに対してERASE、PROGRAMとVERIFY処理を行いません。アプリケーションデータの書き込み対象メモリ空間に合わせて書き込みを行わないセクターを無効に設定して書き込みパフォーマンスのチューニングが可能です。


外部QSPI関連の設定

指定マイコンデバイスにサポートされている場合は、QSPIフラッシュバンクへの書き込みは有効になります。指定されているマイコンデバイスによりまして「Base Address」項目にSPI/QSPIフラッシュメモリ空間のスタートアドレスは設定されます。

QSPIフラッシュの型番入力設定ダイアログはありません。QSPIフラッシュバンクの場合は、QSPIフラッシュのサイズ、フラッシュアルゴリズムは自動認識モードで設定されます。

ラッシュ書き込み可能な(Q)SPIフラッシュ(自動認識モード対応フラッシュ)一覧は以下のURLから確認ください。

https://www.segger.com/products/debug-probes/j-link/technology/cpus-and-devices/supported-spi-flashes/

※J-Flashツールからデバッグポート経由で(Q)SPIフラッシュへの書き込みに関しましては(Q)SPIメモリデバイスの型番・パラメータ設定は不要ですが、マイコンベンダ様の評価ボードの(Q)SPIピン仕様に合わせてフラッシュ書き込みアルゴリズムが作られています。評価ボード環境と異なるピン仕様の(Q)SPIフラッシュへの書き込みは出来ません。

※マイコンデバイスの個別フラッシュローダプログラムによりまして、QSPIフラッシュバンクは、「Sector selection」グループウインドウの表示がなく、セクターの個別選択は出来場合がございます。

その他参考情報:

https://wiki.segger.com/SPI_Flash


外部NORフラッシュ関連の設定

Ext NOR Flash

「Automatically detect flash memory」項目にチェック入れて自動認識設定が有効にされている場合は、「Base Addr」項目に指定されているベースアドレスから外部CFI式NORフラッシュのCFIテーブル情報(セクタ構成、サイズ等)を読み出してフラッシュアルゴリズムを設定します。
ハードウエア仕様の通りに「Organization 8/16/32 Bits x 1/2/4 Chips」項目にフラッシュデバイスの構成(データバスサイズ8/16/32 Bits)を正しく設定してください。

CPUバスからNORフラッシュへの読み書きアクセスを有効にするために必要なバス・クロック・GPIOポートの初期化コマンドを「Init Steps」に設定してください。

Flasherソフトウエアのインストールフォルダに各ベンダー様の評価ボード環境でのNORフラッシュ用J-Flashプロジェクトサンプルが含まれています。サンプルプロジェクトの設定手順を参考にお客様のボード環境の仕様に合わせて「Init Steps」の項目を設定してください。

sample J-Flash

「Automatically detect flash memory」項目からチェックを外して、マニュアルモードでNORフラッシュの設定は可能です。マニュアルモードは、「Select flash device」ボタンで開くダイログからフラッシュデバイス名を選択してください。

NOR Flash Manual modeNOR Flash Manual device

ボード上のフラッシュメモリデバイス名が「Select flash device」ダイログに記載されていない場合は、「Automatically detect flash memory」オプションを有効に設定して自動認識モードを試してください。

「Check manufacturer flash Id」と「Check product flash Id」オプションにチェックを入れて、ボード上のフラッシュのメーカーIDとプロダクトIDの確認が出来ます。チェックオプションを無効に設定した場合はIDの確認を行いません。


Productionモードの設定:

ターゲットボードへの電力共有、書き込みタイムアウト時間、S/N番号、スタンドアロン・モード等の設定を行います。

Production Tab

Target Power Supply

ターゲットボードへの電源出力を設定します。選択可能な電源出力モード:None / VCC5V / VTGT

J-Link/Flasher本体からターゲットボードへの電源供給が不要の場合は、デフォルト設定の「None」を選択してください。

VCC5V

Target-VCC5TJ-Link/Flasher本体の19番ピン経由でターゲットボードに5V電源を出力します。ターゲットボードに電源を入れてからJTAG/SWD通信をスタートするまでの待ち時間(単位:ms)を「Delay before start」項目に設定します。
※「Discharge target on disconnect」オプションはFlasher ATEモデルのみ有効です。

VTGT

Target-VTGTVTGTはFlasher ATEモデル用電源出力オプションです。他のFlasherモデル又はJ-Linkモデルの場合は、VTGTオプションを選択しても「VCC5V」は設定されます。


Reference voltage settings

Target-VTREF

ターゲット側の電源(JTAGコネクタおVTref信号)のレベルモニターの設定を行います。VTref信号の値が「VTref min.」項目の設定値より下がった又は「max」設定値より上がった場合はエラーを表示します。


Program serial number

生産ラインでのターゲット基板ごとのシリアルID番号の設定が出来ます。

SerialNumber

「Program serial number」オプションにチェックを入れて以下の項目を設定します。

項目名説明
Addressシリアル番号を保存する先のアドレス値を指定します。
Lenシリアル番号のデータサイズ(バイト数)を設定します。
Next SN次のシリアル番号の値を示します。S/Nリストファイルが作成されている場合は、「Next SN」項目はS/Nリストファイル内の行番号を示します。
Incrementシリアル番号のインクリメント数を設定します。

Actions performed by "Production Programming"

「Target → Production Programming」コマンドの詳しい内容を設定します。Production Programmingコマンドは以下の順で処理されます。
Erase(Sector又はChipErase) → Program → Verify → Start application → Disconnect

Auto Command

デフォルト設定では、Erase、Program及びVerifyコマンドは実行され、Start application、Disconnectコマンドは無効に設定されています。必要により、Productionモードの設定をカスタマイズしてください。

項目名説明
Eraseモード設定により、フラッシュERASEコマンドを実行します。
  • Selected Sectors:アプリケーションデータイメージに関わる領域のフラッシュセクターのデータを全て消します。
  • Chip:アプリケーションデータイメージに関わる領域に関係なく、フラッシュ領域の全てのセクターのデータを消します。セクターごとにデータが全て消されるので操作時間は長くなります。
Programアプリケーションプログラムのデータをフラッシュに書き込みます。
Verifyフラッシュデータの比較(ベリファイ)を行います。
Start applicationベリファイ後に書き込んだプログラムを起動します。
  • via SFR access:マイコンデバイスのリセット・電源管理モジュールのSFRレジスタを設定してアプリケーションを起動します。
  • via reset pin:JTAGリセット信号を設定してアプリケーションを起動します。
Disconnect afterwards書き込み後にデバッグポートインターフェースを切断します。

Override timeouts

Erase、Program、Verifyコマンドのデバイスレスポンスの待ち時間(単位:ミリ秒)を設定します。

SerialNumber

Performance設定:

Performance

「Perform blank check」を有効に設定した場合は、セクター・Chip ERASEコマンドの前に既にデータが消されているセクターを除く残りのセクターだけを消します。本ページの設定は「Target → Production Programming」と「Target → Manual Programming」コマンドの時に有効です。

Verifyモード設定

  • via CRC:フラッシュメモリデータのCRCを計算して、アプリケーションプログラムのCRC結果と比較して確認を行います。CRCベースのデータ確認の場合は、各データではなくCRC結果のみパソコン側のJ-Flashに渡されます。CRCベースのデータ確認の場合は、Verifyサイクルを短くすることが出来ます。
  • via readback:フラッシュメモリのデータを読み出し、アプリケーションプログラムのデータと比較して確認を行います。

グローバル設定:

J-Flashメニューバーの「Options→Global settings..」で開く「Global setting」ダイログにてその他のグローバル設定を行います。

Global Settings

Save Project files on close

有効に設定した場合はJ-Flashプログラムをクローズする時に操作中のJ-Flashプロジェクトを保存します。

Logging

  • Enable J-Link logfile:チックを入れてJ-Link通信のログ情報を保存するファイル(*.log)を指定します。
  • Enable J-Flash logfile:チックを入れてJ-Flashプログラムのログ情報を保存するファイル(*.log)を指定します。

ログファイルのデフォルトパスは「C:\Program Files\SEGGER\Flasher_Vxxx」となりますので、パスをローカルフォルダに変更又は J-Flashプログラムをマウス右クリックメニューから「管理者として実行」オプションで起動してログ作成をお試しください。


J-Flashプロジェクトを保存:

プロジェクト設定ダイアログが開いている場合は、「OK」ボタンをクリックしてプロジェクト設定を保存してダイアログを閉じます。

「File」→「Save project」又は「Save project as..」メニューコマンドでプロジェクトを保存します。

Save ProjectSave as J-Flash

J-Flashプロジェクトは(*.jflash)ファイルとして保存されます。


J-Flashツールからプロジェクトを開くときには、「File」→「Open project」メニューコマンドで「.jflash」プロジェクトファイルを開きます。

ちなみに、「.jflash」プロジェクトファイルをテキストエディタから開いて設定内容の確認は可能です。

Open with Text editor

書き込むイメージデータのアップロード:

J-Link/Flasher本体をパソコンに接続してパソコンのスタートメニューから「J-Flash」プログラムを起動します。

Connect Flasher

「File → Open data file」コマンドでアプリケーション・データファイル(*.mot、*.srec、*.hex、*.bin、*.raw、*.elf)を開きます。

バイナリデータファイルの場合は、ダイアログボックスからベースアドレスを設定します。
例えば、内蔵フラッシュのベースアドレスが「0x08000000」の場合は、ダイアログボックスに「08000000」を入力します。

Load binary

MOT/HEX/SREC/ELF式データファイルの場合はアドレス情報はイメージファイルに含まれていますのでロードアドレス設定は不要です。

Load file

「Edit → Relocate」コマンドでオフセットアドレスを指定してMOT/HEX/SREC/ELF式データイメージを別アドレスに移動可能です。


複数イメージデータのマージ:

J-Flashツールから以下の手順で複数イメージデータ(例えば、ブートローダとアプリケーションデータ)を一つのデータファイルにマージして1回の書き込みで済ませることも可能です。

  1. 「File → Open data file」コマンドで1つ目のイメージデータをロードします。
  2. 「File → Merge data file..」コマンドで追加するイメージデータをロードします。バイナリデータファイルの場合は、ダイアログボックスからベースアドレスを設定します。
  3. 「File → Merge data file..」コマンドを繰り返して追加のイメージデータをロードします。
  4. 「File → Save data file as..」コマンドでマージされましたイメージファイルを別名のMOT/SREC/HEX式ファイル(例:newdata.mot)として保存します。【Save data file asダイログのファイル種類を選択します】
    Merge file

Production/Autoモード書き込み操作:

ターゲットボードに電源を入れて、J-Flashプロジェクトの「Target → Connect」コマンドでボード側のデバッグポート経由でマイコンデバイスに接続します。ログウインドウから接続結果内容を確認します。

Connect target

Note:

JTAG/SWD接続が正しく出来ない場合の原因:

  • ターゲットインターフェースモードの設定(JTAG?SWD?FINE等)
  • インターフェースクロック設定が高すぎる(デフォルトの4000kHz設定でお試しください)
  • ターゲットボード依存分の初期化設定が不十分(J-Flashプロジェクトの「Init steps」項目に必要な初期化を設定してください)

ターゲットメニューから「Target → Production Programming」コマンドで、Erase → Program → Verifyを実行します。書き込み処理の結果はメッセージダイアログで表示されます。また、詳細はログウインドウに表示されます。

Production Command

マニュアルモード個別コマンド操作:

ターゲットメニューの「Target → Manual Programming」下のコマンドで、Erase(Sector Erase又はChip Erase)、Program、Verify、データ読み取りは実行できます。コマンド処理の結果はメッセージダイアログで表示されます。また、詳細はログウインドウに表示されます。

Manual Command


J-Flashツールメニューコマンド一覧:

Fileメニュー

  • Open data file...:ターゲットボードのフラッシュに書き込むデータのイメージファイルを開きます。イメージファイル形式はIntel HEX(*.HEX)、Motorola S(*.MOT、*.SREC)、バイナリ(*.BIN、*.RAW)又はELF(*.ELF)をサポートします。
  • Merge data file...:2つのデータイメージファイル「*.MOT、*.HEX、*.SREC、*.BIN、*.RAW、*.ELF」をマージして一つのデータイメージファイルとして保存します。未使用の空間は「0xFF」データで埋め込みます。
    事例:File0.binとFile1.binを結合して「File3.bin」として保存します。
    File0.bin -->アドレス 0x0200 - 0x02FF
    File1.bin -->アドレス 0x1000 - 0x13FF
    1. 「Open data file...」コマンドでFile0.binを開きます(指定アドレス:0x0200)。
    2. 「Merge data file...」コマンドでFile1.binファイルを開きます(指定アドレス:0x1000)。
    3. 「Save data file as...」コマンドで結合したデータを「File3.bin」として保存します。0x0300 - 0x0FFF空間(GAP)は0xFFデータで埋め込みます。
  • Save data file:開いているデータイメージファイルを保存します。
  • Save data file as...:開いているデータイメージファイルを別のファイルとして保存します。
  • New Project:デフォルト設定で新規のJ-Flashプロジェクトを作成します。
  • Open Project:現在のプロジェクトを終了して“Open Project”ダイログで指定されたプロジェクトを開きます。複数のプロジェクトを同時に開くことは出来ません。
  • Save Project:現在操作中のJ-Flashプロジェクトを保存します。
  • Save Project as...:現在操作中のJ-Flashプロジェクトを別のプロジェクトとして保存します。
  • Close Project:操作中のJ-Flashプロジェクトを終了します。
  • Save Flasher config file...:J-Flashプロジェクトのコンフィグレーション設定をCFGファイルとして保存します。保存するファイルの名前及びパスは“Save configuration file”ダイログで指定可能です。
  • Save Flasher data file...:Flasher本体にロードするためのデータファイル(*.DAT)をローカルフォルダに保存します。保存するファイルの名前及びパスは“Save data file”ダイログで指定可能です。
  • Download config & data file to Flasher:J-Flashプロジェクト用のコンフィグレーション設定ファイル(*.CFG)及びデータファイル(*.DAT)をFlasher本体の内蔵フラッシュROMに書き込みます。ターゲット側のフラッシュメモリにアクセスを行いません。Flasher本体に保存されるDATファイルは、ユーザープログラムのデータそのままではありません。DATファイルには、ターゲット側のマイコン及びフラッシュコントローラ専用のフラッシュ書き込みプログラム(フラッシュ書き込みアルゴリズム)も含まれています。J-Link本体の場合本コマンドは使用出来ません。
  • Download serial number file to Flasher:ターゲット用S/N番号指定ファイルをSERIAL.TXTとしてFlasher本体に保存します。J-Link本体の場合本コマンドは使用出来ません。
  • Recent Files:最近開いたデータファイルの一覧を表示します。
  • Recent Projects:最近開いたJ-Flashプロジェクトファイルの一覧を表示します。
  • Exit:J-Flashプログラムを終了します。

Editメニュー

  • Relocate...:データファイルのオフセットアドレスを指定又は変更します。
  • Delete range...:データファイルからユーザー指定のデータ空間を削除します。削除するデータのスタート及びエンドアドレスを“Enter address range”ダイログで指定します。
  • Eliminate blank areas...:データファイル内のブランク空間を削除します。

Targetメニュー

  • Connect:JTAG/SWDデバッグポート経由でターゲットのマイコンに接続します。プロジェクト設定のターゲットI/Fモードにて接続及び初期化を行います。
  • Disconnect:ターゲットのデバッグポート接続を解除します。
  • Test:ターゲット接続のテストを行います。“Generates test data...”コマンドでテスト用のデータパターンを作成します。テストデータのサイズは指定可能です。“Test speed...”コマンドで指定空間のメモリアクセスの速度をテストします。“Show CFI info...”コマンドでターゲットのCFI対応フラッシュのCFI Query情報を読み出して表示します。
  • Production Programming:Productionコマンドで、「Connect→Erase→Program→Verify」コマンドを順番に行います。Productionコマンドで実行するコマンド順及びフラッシュセクターの選択はプロジェクト設定で指定します。
    ダイレクトコマンドFnキー:F7
  • Manual Programming:J-Flashツールからマニュアルコマンドで「Connect、Erase、Program、Verify、Readback」操作を行います。

Targetメニュー → Manual Programming

  • Check blank:ターゲットのフラッシュデバイスのブランクチェックを行います。
  • Erase sectors:プロジェクト設定で選択されている全てのセクターをイレーズ(0xFFデータ)します。
  • Erase chip:フラッシュデバイスの全てのデータをイレーズします。
  • Program:データイメージをターゲット上のフラッシュメモリに書き込みます。
  • Program & Verify:データイメージをターゲット上のフラッシュメモリに書き込んでデータ内容を比較(ベリファイ)します。
  • Verify:データファイルとフラッシュデバイスのデータをベリファイします。
  • Read back:フラッシュデバイスのメモリデータを読み出して、新しいデータファイルとして保存します。“Selected sectors”コマンドでデータを読み出す場合は、プロジェクト設定で選択されたセクターのデータを読み出します。
    “Entire chip”コマンドの場合は、全てのセクターのデータを読み出します。
    “Range...”コマンドの場合は、ユーザー指定のフラッシュメモリ空間のデータを読み出してファイルとして保存します。
  • Start Application:ターゲット側のフラッシュに書き込んだアプリケーションを起動します。

Optionsメニュー

  • Project settings...:プロジェクト設定ダイログを開きます。ターゲット接続モード、CPU初期化設定及びフラッシュ関連の設定が可能です。
  • Global settings...:グローバル設定を行います。※J-Flashプロジェクトファイルには保存されません。

Viewメニュー

  • Show project information:プロジェクト情報表示ウインドウを開きます。
  • Show log:ログ表示ウインドウを開きます。

前の質問

J-Flash ツールのコマンドライン操作方法

次の質問

Flasher本体のTCP/IPネットワーク設定方法