更新日:2021-05-26

フラッシュ書き込み用新規 J-Flashプロジェクトを作成します


1ページにまとめて表示

書き込むイメージデータのアップロード:

J-Link/Flasher本体をパソコンに接続してパソコンのスタートメニューから「J-Flash」プログラムを起動します。

Connect Flasher

「File → Open data file」コマンドでアプリケーション・データファイル(*.mot、*.srec、*.hex、*.bin、*.raw、*.elf)を開きます。

バイナリデータファイルの場合は、ダイアログボックスからベースアドレスを設定します。
例えば、内蔵フラッシュのベースアドレスが「0x08000000」の場合は、ダイアログボックスに「08000000」を入力します。

Load binary

MOT/HEX/SREC/ELF式データファイルの場合はアドレス情報はイメージファイルに含まれていますのでロードアドレス設定は不要です。

Load file

「Edit → Relocate」コマンドでオフセットアドレスを指定してMOT/HEX/SREC/ELF式データイメージを別アドレスに移動可能です。


複数イメージデータのマージ:

J-Flashツールから以下の手順で複数イメージデータ(例えば、ブートローダとアプリケーションデータ)を一つのデータファイルにマージして1回の書き込みで済ませることも可能です。

  1. 「File → Open data file」コマンドで1つ目のイメージデータをロードします。
  2. 「File → Merge data file..」コマンドで追加するイメージデータをロードします。バイナリデータファイルの場合は、ダイアログボックスからベースアドレスを設定します。
  3. 「File → Merge data file..」コマンドを繰り返して追加のイメージデータをロードします。
  4. 「File → Save data file as..」コマンドでマージされましたイメージファイルを別名のMOT/SREC/HEX式ファイル(例:newdata.mot)として保存します。【Save data file asダイログのファイル種類を選択します】
    Merge file

Production/Autoモード書き込み操作:

ターゲットボードに電源を入れて、J-Flashプロジェクトの「Target → Connect」コマンドでボード側のデバッグポート経由でマイコンデバイスに接続します。ログウインドウから接続結果内容を確認します。

Connect target

Note:

JTAG/SWD接続が正しく出来ない場合の原因:

  • ターゲットインターフェースモードの設定(JTAG?SWD?FINE等)
  • インターフェースクロック設定が高すぎる(デフォルトの4000kHz設定でお試しください)
  • ターゲットボード依存分の初期化設定が不十分(J-Flashプロジェクトの「Init steps」項目に必要な初期化を設定してください)

ターゲットメニューから「Target → Production Programming」コマンドで、Erase → Program → Verifyを実行します。書き込み処理の結果はメッセージダイアログで表示されます。また、詳細はログウインドウに表示されます。

Production Command

マニュアルモード個別コマンド操作:

ターゲットメニューの「Target → Manual Programming」下のコマンドで、Erase(Sector Erase又はChip Erase)、Program、Verify、データ読み取りは実行できます。コマンド処理の結果はメッセージダイアログで表示されます。また、詳細はログウインドウに表示されます。

Manual Command


前の質問

J-Flash ツールのコマンドライン操作方法

次の質問

Flasher本体のTCP/IPネットワーク設定方法